Important Message from Foscam Digital Technologies Regarding US Sales & Service

Foscam.US (aka Foscam Digital Technologies and now Amcrest Technologies) is an independent United States based distributor of "Foscam" branded products. We have been offering telephone support, US local warranty and building the Foscam brand in the US for the past 7 years. Based on our experiences with Foscam and feedback from end users we have launched our own new and improved line of wireless IP cameras and security systems under the Amcrest brand. Working in partnership with the second largest security camera manufacturer in the world, Amcrest was founded with a deep commitment to end-user privacy and security, highly reliable software and hardware as well a seamless and intuitive user experience. For more information, please visit www.Amcrest.com

If you are having trouble with your Foscam cameras, we sincerely apologize for this inconvenience and would love to help. For technical support, response to inquiries and for obtaining replacements for any Foscam IP Cameras or NVR products, please reach out to tech@foscam.com or call 1-844-344-1113.

If you are interested in exchanging your Foscam camera for an Amcrest camera, we can offer you a massive loyalty discount, even if you are out of warranty. Please send an email to support@amcrest.com, sales@amcrest.com or call 1-888-212-7538

If you are subscribed to Foscam Cloud (www.foscamcloud.com), please contact cloud@foscam.us for support.

If you currently use the manufacturer's cloud service (www.myfoscam.com or linked in any way to www.foscam.com), you will need to contact them directly for support, at www.myfoscam.com.


Foscam F19821W V2 "Password Format Error"

Users can ask and answer questions regarding Foscam IP Cameras

Moderators: mycam, FOSCAM

Foscam F19821W V2 "Password Format Error"

Postby DTS » Sun Apr 13, 2014 5:59 am

Hi, I am trying to connect to my wireless access point, it was working fine until I decided to change my wireless password to be a bit more secure, 20 characters in length combination of upper/lower characters and special characters, now when trying to save the new password a popup appears in the bottom left hand corner entitled "Tips" with a message "Password Format Error" so it's unable accept the new password for some reason, looking at the WebGUI it mentions the password restrictions are 63 characters in length including numbers,letters and symbols.

Things have tried this far.
Using different browsers Chrome and IE and different OS's all encounter the same issue.

System firmware version:1.4.1.8
Web UI version:2.11.1.6

One thing that I have notice is in the WebGUI it mentions a few special characters except the + sign which is one of the characters used in my password, could this be the reason ?

The user guide doesn't mention anything about password restrictions
http://www.foscam.com/Private/ProductFi ... manual.pdf
Is there away to get more logging information from the camera like pointing it to syslog server for example as the pop up message is meaningless?
DTS
 
Posts: 1
Joined: Sun Apr 13, 2014 5:28 am

Re: Foscam F19821W V2 "Password Format Error"

Postby home_automator » Tue May 27, 2014 8:24 pm

Did you find a solution to this? I also have a password with a special character and get the same error message. Is it really limited to the listed characters in the webgui?

I have too many people/devices connected with the old password to change it just for this.

Thanks!
home_automator
 
Posts: 1
Joined: Tue May 27, 2014 8:21 pm

Re: Foscam F19821W V2 "Password Format Error"

Postby KHickenbottom » Sun Jun 15, 2014 3:02 pm

I can not connect my two new cameras on wireless, I get the "password format error". Is there going to be a fix?
KHickenbottom
 
Posts: 2
Joined: Sun Jun 15, 2014 2:56 pm

Re: Foscam F19821W V2 "Password Format Error"

Postby rojasnet » Fri Jul 04, 2014 9:48 am

I am having the same problem with the "Password Format Error" error on an FI9826P camera. I have a very long password with a mixture of uppercase and lowercase letters, numbers, and several symbols. I have emailed support. Hopefully I will hear something back from them.
rojasnet
 
Posts: 1
Joined: Fri Jul 04, 2014 9:31 am

Re: Foscam F19821W V2 "Password Format Error"

Postby carefreebob » Sat Jul 12, 2014 6:34 pm

I have just received a 9826P and to my surprise, it does not connect to my wireless router because the special character "=" is not accepted by the camera. Has anyone heard from tech support as to whether there will be a patch for this limitation. I own 8 older cameras and run up to 20 wireless devices at each of two homes so I do not want to reprogram everything. I guess the new camera is returnable but that is not my preferred solution.

Ideas anyone?
carefreebob
 
Posts: 1
Joined: Sat Jul 12, 2014 6:13 pm

Re: Foscam F19821W V2 "Password Format Error"

Postby TheUberOverLord » Sun Jul 13, 2014 9:13 am

Not sure "=" will ever be supported as a valid character for User credentials.

While some IP Cameras may support the equal sign. Foscam IP Cameras support CGI commands. Which can be used in web browsers as a URL. Because of this the equal sign would/does cause a conflict because its meaning is the value of a URL parameter.

Don
TheUberOverLord
 
Posts: 13110
Joined: Fri Jun 22, 2012 11:52 pm

Re: Foscam F19821W V2 "Password Format Error"

Postby andih » Wed Aug 13, 2014 9:48 pm

I just received my first Foscam camera, FI9821W V2 and as I went through the setup and tried to configure the wireless connectivity, I was very surprised to see that it doesn't accept my password which contains the + and the & signs. These are perfectly valid WPA2 characters. Why does this camera have such a limited set of valid password characters?

Please provide a patch so one can use all possible special characters because I too have many devices and people connected to the wireless network and having to change the WPA password for all those would be a huge headache.

So for now I'm forced to hook it up via a long ethernet cable which sucks too.
andih
 
Posts: 1
Joined: Wed Aug 13, 2014 9:41 pm

Re: Foscam F19821W V2 "Password Format Error"

Postby FOSCAM » Thu Aug 14, 2014 4:16 am

Hello,

About the Special Characters of shared key(wifi password)
please don't use:
& =

You can use:
- _ # $ % + ! ^

We don't recommend you use:
* ( ) & \ / ? ' “ |; : [] {}
FOSCAM
 
Posts: 766
Joined: Thu Nov 03, 2011 9:11 pm

Re: Foscam F19821W V2 "Password Format Error"

Postby tomaustin1 » Mon Sep 01, 2014 7:46 pm

I have this same problem where my wifi password has +,?, and =. Changing the pw for all my devices is a nightmare. I used the following to get around the problem in the camera and make the camera use my password that has the forbidden characters.

Short version:
Type in this URL. Where I put {XYZ} replace it with the actual value. The key to making this work is the value of {YOURWIFIPASSWORD}. You need to escape the special charaters - that is what foscam is not doing correctly. To do this go here: http://www.w3schools.com/tags/ref_urlencode.asp The "try it yourself" box lets you put in your wifi password and it escapes everything properly. Put this escaped value in for {WIFIPASSWORD}
http://{YOURIPADDRESS}:88/cgi-bin/CGIProxy.fcgi?usr={YOURUSERNAME}&pwd={YOURPASSWORD}&cmd=setWifiSetting&isEnable=1&isUseWifi=0&ssid={YOURSSID}&netType=0&encryptType=3&psk={YOURWIFIPASSWORD}&authMode=2&keyFormat=0&defaultKey=1&key1=&key2=&key3=&key4=&key1Len=64&key2Len=64&key3Len=64&key4Len=64&1409617133497

The long version of what I did. This will be more helpful if you have a different version of the web console software, or you want to piece together what I did.
1. Log into the console using google chrome. Click CTRL+SHIFT+I to open the developer console. Click the second tab that says Network. This will allow you to see all the web requests made by your browser.
2. Navigate to the page where you enter your wireless info. Put in a fake value with no special characters and click save. Watch in the network tab to see the request your browser makes to the server.
3. Replace the fake value you entered for the wifi password with the real value URL encoded (see above about going to a site to help you URLencode the value).
4. Take the resulting URL and put it into a web browser. (Make sure you get the value of the URL that is not encoded) This causes the value to be saved properly.
tomaustin1
 
Posts: 1
Joined: Mon Sep 01, 2014 7:29 pm

Re: Foscam F19821W V2 "Password Format Error"

Postby kman » Fri Oct 10, 2014 6:54 pm

Are you KIDDING me? There is a way around this problem, and Foscam's coders are too lazy to implement it properly such that NORMAL (and valid) ASCII characters can't be used for the wifi password? Instead, we users have to jump through crazy hoops to try to make it work? Their recommendation is "don't use these normal characters"?

That does it, I'm returning this camera. Shame, because it seemed to work fairly nicely. But I refuse to accept this sort of absurdity and laziness (to be generous and assume it's not pure incompetence) from a company.
kman
 
Posts: 1
Joined: Fri Oct 10, 2014 6:49 pm

Next

Return to Technical Support

Who is online

Users browsing this forum: No registered users and 3 guests