Important Message from Foscam Digital Technologies Regarding US Sales & Service



We, Foscam.US (aka Foscam Digital Technologies and now Amcrest Technologies), are an independent United States based distributor of "Foscam" branded products. We have been offering telephone support, US local warranty and building the Foscam brand in the US for the past 7 years. However, we are deeply saddened to report that, even after all of this, our overseas suppliers have decided to undercut us and supply to our major customers directly. For this reason, we have no choice but to suspend telephone support for all Foscam branded products. If you have purchased a Foscam camera directly from us or from one of our authorized retailers, technical support is still available via email at support@foscam.us.


For customers who have not purchased from us directly, we advise you to please contact Foscam Shenzhen or the distributor which you have purchased from. In the meantime, we have launched our own new brand of IP cameras called Amcrest, which has superior quality products and full telephone technical support 7 days per week. We hope you can support us in our new venture. For more information, please visit www.Amcrest.com.



Plug-in version

Users can ask and answer questions regarding Foscam IP Cameras

Moderators: mycam, FOSCAM

Plug-in version

Postby jens » Fri Nov 29, 2013 9:40 am

Hi,
I have just started the installation of a FI9826W. I am using Windows 8.1 64-bit with Chrome 32-bit. The Foscam Chrome plug-in version I get downloaded is 2.0.1.4 but Norton 360 doesn't like it and actually removes it. Only by manually installing it I get a live picture.

Is there a newer version available that Norton will accept?

When I updated other parts of the system I see the plug-in version 2.0.1.7 mentioned (but not included in the available updates)?
jens
 
Posts: 1
Joined: Fri Nov 29, 2013 9:07 am

Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 3 guests